Samsung smart TV cannot connect to wifi

phoenix55

Well-Known Member
Joined
Jun 22, 2007
Messages
178
My Dad has a new Samsung Series 7 smart TV

He has an Unifi UAP AC-LR wireless access point

When he tries to add the WiFi access point as a network connection on the TV, it fails to connect with error "wireless network disconnected"

He is able to connect to the TPLink wireless router without a problem so am guessing it's something on the Unifi

We tried all the steps in this video, but setup not working


How can I get the TV to connect to the Unifi WiFi network?
 

"D"

Expert Member
Joined
Oct 20, 2006
Messages
2,214
Screenshot_20200613-185957.png

As you can see, your AP device is simply too fancy! It has identified the Samsung TV as an enemy!
 
Last edited:

"D"

Expert Member
Joined
Oct 20, 2006
Messages
2,214
Perhaps connect that new TV to the AP (or the router) via LAN, so the TV has a chance to connect to the Internet, so it can download its own various updates. You could also update the TV firmware, if an update is available.

You could also change authentication settings on the AP, edit/assign exceptions in its connection configurations regarding the Samsung TV, as well as update the firmware on the AP.
 

powermzii

Expert Member
Joined
Jun 4, 2007
Messages
3,945
TO the point above - is your Dad's wifi a combined SSID, i.e both 2.4 and 5ghz on the same SSID name? My TV had issues with this setup. I eventually just ran a cable to it and stopped messing around with the Wifi
 
  • Like
Reactions: "D"

Ares1000101

Senior Member
Joined
Jun 6, 2011
Messages
587
TO the point above - is your Dad's wifi a combined SSID, i.e both 2.4 and 5ghz on the same SSID name? My TV had issues with this setup. I eventually just ran a cable to it and stopped messing around with the Wifi
This. I have unifi and when I combined frequencies under 1 SSID the TV got confused and wouldn't connect. Had to split it back into 2.4 & 5ghz.
 

SauRoNZA

Honorary Master
Joined
Jul 6, 2010
Messages
38,686
Disable the automatic optimise network configuration on the Unifi Controller.
 
Last edited:

SauRoNZA

Honorary Master
Joined
Jul 6, 2010
Messages
38,686
This. I have unifi and when I combined frequencies under 1 SSID the TV got confused and wouldn't connect. Had to split it back into 2.4 & 5ghz.

No you don’t need to separate it.

Just disable automatic configuration and do it yourself.

Settings > Network Settings > Optimizations

Turn off Auto-Optimise Network.

Now go back to your SSID configuration and put the following ON.

Enable Multicast Enhancement
Enable UAPSD
Combine Name/SSID

I wouldn’t recommend Optimize For High Performance unless you have a number of AP’s in perfect proximity to all 5ghz devices.
 
Last edited:

Ares1000101

Senior Member
Joined
Jun 6, 2011
Messages
587
No you don’t need to separate it.

Just disable automatic configuration and do it yourself.

Settings > Network Settings > Optimizations

Turn off Auto-Optimise Network.

Now go back to your SSID configuration and put the following ON.

Enable Multicast Enhancement
Enable UAPSD
Combine Name/SSID

I wouldn’t recommend Optimize For High Performance unless you have a number of AP’s in perfect proximity to all 5ghz devices.
Aaah will give this a try! Thanks
 

access

Honorary Master
Joined
Mar 17, 2009
Messages
11,785
i just created a separate guest network for the tv stuff and it does not do this anymore. /touchwood
 
Top