WiFi Calling disappeared

Jerorojau

New Member
Joined
Dec 29, 2019
Messages
4
Hi All
I'm with Vodacom and had a Samsung S9. We have a farm with no reception, only Internet, and my WiFi calling worked just fine. My phone crashed and I got a secondhand S9+, put in my old sim and there is no more option to switch on WiFi calling. First I thought it was the phone, but if I put in my wife's MTN sim, the WiFi calling option is available. Same with her S8. She's got WiFi calling available, and when I put my sim in her phone, the option disappears.

As I said, I did WiFi calling with the same sim on my previous phone. Two days ago I went to Vodashop and asked them to activate my Voice over Wi-Fi. They did and I received the message: "You have been successfully provisioned with the Wi-Fi Calling VAS. Enable the Wi-Fi Calling option in your device to make Wi-Fi Calls. Contact customer care or get Wi-Fi Calling product details in www.vodacom.co.za"

Nothing changed. What else do I have to do? Anybody?

Johan
 

Fcon_Vpro

Expert Member
Joined
Oct 9, 2007
Messages
1,108
Hi All
I'm with Vodacom and had a Samsung S9. We have a farm with no reception, only Internet, and my WiFi calling worked just fine. My phone crashed and I got a secondhand S9+, put in my old sim and there is no more option to switch on WiFi calling. First I thought it was the phone, but if I put in my wife's MTN sim, the WiFi calling option is available. Same with her S8. She's got WiFi calling available, and when I put my sim in her phone, the option disappears.

As I said, I did WiFi calling with the same sim on my previous phone. Two days ago I went to Vodashop and asked them to activate my Voice over Wi-Fi. They did and I received the message: "You have been successfully provisioned with the Wi-Fi Calling VAS. Enable the Wi-Fi Calling option in your device to make Wi-Fi Calls. Contact customer care or get Wi-Fi Calling product details in www.vodacom.co.za"

Nothing changed. What else do I have to do? Anybody?

Johan
So just a bit of a guess but might have to do with the firmware on the phone. You might need Vodacom specific firmware to get Vodacom WiFi calling working. Compare the firmware versions to what is on sammobile.com

Does your wife get WiFi calling on MTN or are you just talking about the option to enable it on her phone? As far as I know WiFi calling is in testing at MTN and not released as yet.
 

Jerorojau

New Member
Joined
Dec 29, 2019
Messages
4
So just a bit of a guess but might have to do with the firmware on the phone. You might need Vodacom specific firmware to get Vodacom WiFi calling working. Compare the firmware versions to what is on sammobile.com

Does your wife get WiFi calling on MTN or are you just talking about the option to enable it on her phone? As far as I know WiFi calling is in testing at MTN and not released as yet.
Thanks for the reply. I will insert my sim in a Vodacom phone and see what happens.

No my wife can't make WiFi calls, but she also didn't apply for it. Not sure if MTN has it.
 

mono2

Active Member
Joined
Nov 14, 2005
Messages
60
I have similar problem with my s9.

What I find works is put the phone in airplane mode then enable wifi only.. usually gets wifi calling to come back.

You can also try restart the phone and phone above step that works for me.

It's almost like the phone prefers GSM calling over wifi even with poor GSM signal
 

Jerorojau

New Member
Joined
Dec 29, 2019
Messages
4
I have similar problem with my s9.

What I find works is put the phone in airplane mode then enable wifi only.. usually gets wifi calling to come back.

You can also try restart the phone and phone above step that works for me.

It's almost like the phone prefers GSM calling over wifi even with poor GSM signal
Hi thanks for the replies. Seems the problem is that, if you are a Vodacom customer, you need to have a “Vodacom phone" to do WiFi calling. I put my sim in another Vodacom-supplied phone and everything worked fine.
 

[OUPA]MrNutz

Expert Member
Joined
Jan 21, 2005
Messages
1,764
I have to use the "Wifi calling" (android app) to manually "force" the phone preference to call over wifi.
 

Fcon_Vpro

Expert Member
Joined
Oct 9, 2007
Messages
1,108
Hi thanks for the replies. Seems the problem is that, if you are a Vodacom customer, you need to have a “Vodacom phone" to do WiFi calling. I put my sim in another Vodacom-supplied phone and everything worked fine.
You can probably load the Vodacom firmware onto your s9. Download the firmware from sammobile. Google how to do it and if it will work for your phone but it should. I used to run German firmware on my old Vodacom Samsung note 4. You just going in the opposite direction to add their firmware on.
 

Jzl

Member
Joined
Jan 12, 2020
Messages
15
I have to use the "Wifi calling" (android app) to manually "force" the phone preference to call over wifi.
"Wifi calling" (android app) has a few reports of Malware in the comments. Can anyone confirm if it has or not?
 
Top