Ethernet Won't Work

PseudZ

Expert Member
Joined
May 28, 2008
Messages
1,217
Sorry if this has been posted before, I have Googled and searched but nothings helping.

I have xubuntu on an old PC, but I cannot get the Ethernet to work. I have it connected to my router and the router light comes on and the light on the PC comes on, then i select auto etho or so, it will search a bit, but then say disconnected. The 2 other machines on the network run XP.

ifconfig:
ifconfig
eth0 Link encap:Ethernet HWaddr 00:00:21:c2:ff:ff
inet6 addr: fe80::200:21ff:fec2:ffff/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:7395 overruns:0 frame:14790
TX packets:0 errors:14 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:6750 (6.7 KB)
Interrupt:5 Base address:0x4800

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:10 errors:0 dropped:0 overruns:0 frame:0
TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:460 (460.0 B) TX bytes:460 (460.0 B)
dhclient eth0:

Listening on LPF/eth0/00:00:21:c2:ff:ff
Sending on LPF/eth0/00:00:21:c2:ff:ff
Sending on Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 6
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 9
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 18
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 4
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
I know it's something to do with DHCP but no idea how to go about it.
Anyone know of a solution?
Thanks
 

bdt

Executive Member
Joined
Jun 7, 2004
Messages
6,739
Damndest thing: I GOOG'd that MAC address and found a word-for-word identical post of your problem here :rolleyes: where, it seems. you're floundering as much as you are here. OK, bearing in mind that I'm VERY n00b with 'buntu and NIXen in general, but here goes with some elementry fault-finding (expect better stuff from the cognoscenti, when they see this)...

Your 'ifconfig' shows that you have an eth0 device, the question here is 'is it real?' You know that it's live 'cos the lights come on when the cable gets connected, so:
  • is it enabled in BIOS (if this is an option)? Rationale: I watched a pal plug a PCIe video card into a machine that proceeded NOT to work 'cos of a BIOS setting: he changed that and voila, we had output from the card.
  • what output does 'dmesg' give WRT eth0? Rationale: there's something very hinky with modern/current 'buntu not seeing an OLD (and therefore 100TX ..and therefore very likely a Realtek 8139 IC) NIC, follow up on that.
  • I'm not familiar with xubuntu menu structure to where you can get to the networking setup via the GUI but, from there or the shell, why not give eth0 a static IP address in your local network range and then ping your router? Most people don't change the range so it's likely to be 192.168.0.* (I use 10.0.0.* because I REALLY hate the extra typing (and, as a notebook user, have only the top row to use) ..a point worth considering!) :rolleyes:
 

HvRooyen

Senior Member
Joined
Aug 14, 2006
Messages
520
On your router:
Is DHCP server enabled?
Is MAC address filtering perhaps on?
As mentioned above: Try static address, see if you can ping other machines.
 

dj_jyno

Expert Member
Joined
Sep 22, 2007
Messages
3,354
PseudZ, check the status of the LAN connection of one of the XP machines. It should say "Assigned by DHCP" under Address Type on the Support tab. If it doesn't say that, it means that your router's DHCP server is not enabled. This is most probably the case, since Xubuntu also indicates that it can't find an active DHCP server on the network.

On your router:
Is DHCP server enabled?
Is MAC address filtering perhaps on?
+1
 

.Froot.

Executive Member
Joined
Aug 6, 2007
Messages
9,261
If it's not just a normal networking problem, you haven't by chance created a pppoe connection? There is a bug in Ubuntu with using PPPOEconfig that your network interface stops working until you fix your /etc/network/interfaces file.
 
Top