Slow Google services on Rain?

thomas37

Member
Joined
Apr 29, 2006
Messages
17
I am having a problem with any Google related services on Rain 5G. It's only been an issue in the last day or two. Google search times out or take a long time to load. Any website (including this forum) that uses some sort of Google service takes forever to load. I do not have a speed problem with anything else. My speed tests run at around 380 Mbps download with 12 Mbps of upload speed. Anybody experiencing the same?
 

Attachments

BlueOne

Member
Joined
Sep 19, 2016
Messages
29
I was saying this to my wife just last night. I was seeing Youtube sometimes needs a nudge to load, or sites with Google ads take awhile to get going.
 

kabusi

Senior Member
Joined
Nov 19, 2018
Messages
956
I was saying this to my wife just last night. I was seeing Youtube sometimes needs a nudge to load, or sites with Google ads take awhile to get going.
I was noticing it was extremely sluggish and timing out on 4G as well when it was trying to access Google services.
But I have generally appalling speed so just thought it's business as usual at Rain.
 

mrlgm007

Senior Member
Joined
May 14, 2010
Messages
657
this was a issue on 4G and had to use a VPN even changing DNS did not work for me please dont say we going down this road again :mad:
 

kabusi

Senior Member
Joined
Nov 19, 2018
Messages
956
this was a issue on 4G and had to use a VPN even changing DNS did not work for me please dont say we going down this road again :mad:
Yes I had the Google issue previously when my speeds were around 5Mbps.
With Rain 4G everything these days is a struggle. Think this has to do with Vodacom being involved in managing the 4G infratructure.
With the 5G service being handled only by Rain, at least the users get assisted most of the time.
 

cavedog

Honorary Master
Joined
Oct 19, 2007
Messages
15,604
Started yesterday. I get 350Mbps speedtest to local and 300Mbps to international but google related services is slow.

Could be a peering issue at JHB. Once a download starts in gdrive though it seems fine.
 

mrlgm007

Senior Member
Joined
May 14, 2010
Messages
657
If the mother in law asks what is wrong with YouTube then you know.

let me do some tests
 

Kawak

Well-Known Member
Joined
Mar 14, 2007
Messages
465
Just activated my rain sim, wonderful speeds on speedtest 600 local 350 internationa but youtube wont load? WTF? guess im sticking with fibre.
 

RichardG

Honorary Master
Joined
Apr 6, 2005
Messages
11,678
This issue has been ongoing have to refresh my browser a few times in ordrr to get throughput to Gmail, Google and YouTube.. Hope they sort out their peering issue
 

Jimmy

Well-Known Member
Joined
Apr 12, 2011
Messages
362
Same here. My mother was complaining about slow Youtube speeds yesterday.
 
Top