Telkom IP Voice Service

For everyone with a Fanvil phone (bought the phone (X3SP) to play around with VOIP and decided to stick with it), update to the latest software first. Then make sure your phone is provisioned on the Telkom network. It should work thereafter.

Settings_1.JPG
 
Hi Treid your solutions and managed to get onto Network but now when I place a call it says line forebidden does anyone have a solution for this
 
I have a Yealink T21P, (Not from Telkom), I did the setup via the web interface not via the telkom provisioning menu..

Here's the setup I used (note the proxy/outbound server that telkom gives you is incorrect, use the one listed below instead)

Register Name Format: [email protected]
Username Format: +27xxxxxxxxx
Outbound Server (Proxy): 165.148.1.54
Server Host: ppr2.ims.telkom.co.za

*ps. My phone is a very old model/version, so the layout might be a little different on the newer models.
Hi I will Trys this, I am going crazy....Telkom support absolutely sucks.
 
Hi I will Trys this, I am going crazy....Telkom support absolutely sucks.
For support with your Telkom VoIP products rather phone 10219 (Business) and not 10217. The latter support team doesn't know about the product and therefore can't help.
 
For support with your Telkom VoIP products rather phone 10219 (Business) and not 10217. The latter support team doesn't know about the product and therefore can't help.
I will right now as it still i cannot come right...
 
Just set up my ported IPvoice on telkom fibre, works like a charm, voice quality is great

Activated the config in portal, needs number and password, i chose 'use own device'

plugged in a old POTs telephone (Plain Old Telephone) into the Dlink DWR-956M (fibre and LTE) and in the VIOP section added incoming ,outgoing servers, username and password

Basic Setup
Domain - Register Server : ctb.ims.telkom.co.za Port:5060
SIP Proxy - Outbound Server : ipv.so.telkomvoip.co.za Port:5060
Connection1 : User Name : [email protected]
Password ###







View attachment 1048085

View attachment 1048077

View attachment 1048071
Hi, Besides having a call plan, Does Telkom charge for the IP line. Initially Telkom told me that the analogue phone cannot be connected to the dlink router and was asked to buy an IP Yealink phone ... which I did. I was charged for my plan only .. "closer basic bolt on" - R40. I could not believe that the analogue would not work, so I used google and across your post. I got the analogue phone working. My next statement included an additional charge for IP voice. Is that correct billing for using the IP voice?
 
Hi, has anyone got Telkom VOIP working on the Zoiper App?

I have it working on the Yealink phone but want to test on Zoiper. I mainly use Zoiper for my Switchtel line which works 100%, but with telkom it doesn't always connect.
 
Hi, has anyone got Telkom VOIP working on the Zoiper App?

I have it working on the Yealink phone but want to test on Zoiper. I mainly use Zoiper for my Switchtel line which works 100%, but with telkom it doesn't always connect.

I have the same question - may go the Telkom VOIP route but want to know if there's a softphone app I can use with this account.
 
For everyone with a Fanvil phone (bought the phone (X3SP) to play around with VOIP and decided to stick with it), update to the latest software first. Then make sure your phone is provisioned on the Telkom network. It should work thereafter.
Thanks Jamster03. I could not have configured my VOIP phone without your help. I have been dealing with Telkom for 3 weeks without progress. The I found your post. Here's my config for YEALINK W60B base station. ctb.ims.telkom.co.za, ipv.we.telkomvoip.co.za1645865847389.png
 
Yealink W60B base station config for Telkom VOIP. With HELP from Jamster03.
ctb.ims.telkom.co.za
ipv.we.telkomvoip.co.za
1645866123480.png
 
Has anyone been able to setup a telkom voip account on a Gigaset A510IP? I received an email today containing the assigned phone number, after which I changed the voip password on the Telkom website and received a confirmation email stating that the service is registered. However when I setup the account on the Gigaset base station, it shows a 'registration failed' error message even though the password is correct.

Update
When I checked this morning the registration on the base station was successful. I also managed to make outbound calls and so far the sound quality is very good.

I'll leave the screenshots below in case someone else owns a Gigaset A510IP phone.

1646763092377.png

1646763321916.png

1646763375626.png
 
Last edited:
I got this working on Microsip on PC for anyone that wants to test their VOIP account on Telkom works. The SIP authentication password has to be set by logging into Telkom website and editing your VOIP details.

Went 3 times into Telkom to migrate my landline because of useless staff. Its worth the hassle in the end because its a huge savings in montly subscription. I bought the Grandstream HT801 ATA convertor from Geewiz and it works well.


1649253884821.png


I also managed to get my details into Zoipher beta on Android phone and it worked.

1649254684070.png
 
Just set up my ported IPvoice on telkom fibre, works like a charm, voice quality is great

Activated the config in portal, needs number and password, i chose 'use own device'

plugged in a old POTs telephone (Plain Old Telephone) into the Dlink DWR-956M (fibre and LTE) and in the VIOP section added incoming ,outgoing servers, username and password

Basic Setup
Domain - Register Server : ctb.ims.telkom.co.za Port:5060
SIP Proxy - Outbound Server : ipv.so.telkomvoip.co.za Port:5060
Connection1 : User Name : [email protected]
Password ###







View attachment 1048085

View attachment 1048077

View attachment 1048071
Once Telkom will sends you an email: "Telkom SA: IP Voice nnnnnnnnnn Device Configuration Success" with a link to choose your own password, you are good to go, but you are on your OWN! HOW to get to this point is another story, without ANY timelines.

This link will give you ONLY 3 lines of very basic info:

This forum guided me how to set up My DLink DWR-956M using an analog Telkom handset:
Applications
VoIP
Basic settings
Basic Setup
Port: 5060
Register Server: ctb.ims.telkom.co.za
Proxy: ipv.we.telkomvoip.co.za (Note the change highlighted - figured it out from Telkom link above)
Port: 5060
Connection 1 - Enable
User Name: [email protected]
Password: ??????????????

There is a STATUS item at the very top of the router admin menu. If VOIP status shows REGISTERING all the time, then the details are incorrect!

Managed to set it up on Tuesday 16 August 2022, no issues.
 
Has anyone been able to setup a telkom voip account on a Gigaset A510IP? I received an email today containing the assigned phone number, after which I changed the voip password on the Telkom website and received a confirmation email stating that the service is registered. However when I setup the account on the Gigaset base station, it shows a 'registration failed' error message even though the password is correct.

Update
When I checked this morning the registration on the base station was successful. I also managed to make outbound calls and so far the sound quality is very good.

I'll leave the screenshots below in case someone else owns a Gigaset A510IP phone.

View attachment 1262186

View attachment 1262188

View attachment 1262190
 
If i knew this would be such a hustle with telkom i would have gone with vox. No email with intrusions... so useless customer service.
Trying to aďd the number with the server details doesnt work... 1 degit two many
 
Back
Top