*180# not working – Connection problem or invalid MMI code

rpm

Admin
Staff member
Joined
Jul 22, 2003
Messages
63,943
#1
I am on Telkom and am trying to convert airtime into a data bundle.

However, when I use the *180# USSD code, I get the error “Connection problem or invalid MMI code”.

I am out of data – can that be the problem?
 

Pho3nix

The Legend
Joined
Jul 31, 2009
Messages
27,100
#2
Nah, it happens from time to time lately. You can buy Data either from the telkom app or going to telkom.co.za and signing in via simcard.
 

rpm

Admin
Staff member
Joined
Jul 22, 2003
Messages
63,943
#3
Nah, it happens from time to time lately. You can buy Data either from the telkom app or going to telkom.co.za and signing in via simcard.
Thanks for the feedback. So basically the USSD system gives problems from time to time?
 

DanDango

Executive Member
Joined
Sep 4, 2013
Messages
6,867
#4
I am on Telkom and am trying to convert airtime into a data bundle.

However, when I use the *180# USSD code, I get the error “Connection problem or invalid MMI code”.

I am out of data – can that be the problem?
I'm getting the same error on both *180# and *123# . I have 3gb mobile data remaining, not a data problem maybe telkom server problem.
 

rpm

Admin
Staff member
Joined
Jul 22, 2003
Messages
63,943
#6
Yeah. Experienced it on two different sims. Been a week since I saw the error though. Some people been asking Telkom about it since June.
Thanks for the info. It is quite astonishing that an operator would not be very concerned about a sales channel giving problems.
 

rpm

Admin
Staff member
Joined
Jul 22, 2003
Messages
63,943
#7
An update: This morning *180# worked perfectly, and I was able to load a data bundle as expected.
 
Top