Afrihost RAIN seems inactive

KulaniNeville

New Member
Joined
Feb 19, 2018
Messages
4
I bought the Fixed wireless Promo from afrihost and got it delivered on the 8th of Feb 2018. I have perfect coverage. When I viewed the router via the browser login, the sim appeared inactive with no network bar (grey'd out). Log multiple support tickets to Afrihost and didn't get a straight answer or a solution. Even today on the 19 of Feb, the situation is the same. I was forced to use their APN MTN 1 GB for R58/pm with 1GB topups costing R99 despite having signed up to pay R300 pm for 25GB with 10GB topups costing R10. The APN MTN works perfectly but the RAIN simcard seem inactive. Data is allocated to me but I can't use it because the SIM is inactive.

Anyone having similar issues? Especially those that bought the promo this year.
 

Attachments

KulaniNeville

New Member
Joined
Feb 19, 2018
Messages
4
Just tried that, switched to the RAIN profile even, still no service. Even tried manual network, found only 65519 4G, 65538 4G and 65514 4G availbale, can't connect to any. The rest of the networks are forbidden.
 
Last edited:

KulaniNeville

New Member
Joined
Feb 19, 2018
Messages
4
Apparently the site says I don't t have coverage anymore, even thought the site said I have coverage when I bought it.
 

AfriFella

Afrihost
Company Rep
Joined
Jun 2, 2015
Messages
2,713
Apparently the site says I don't t have coverage anymore, even thought the site said I have coverage when I bought it.
Hi KulaniNeville. I'm really sorry to hear that you're battling with activation. :( If you're outside of coverage, it could explain your problem. It sounds strange to me that the map would update that harshly, but I'd love to take a look into this. Please feel free to PM me your account info and we'll take it from there.
 
Top