Sharing a 3G connection via WiFi router and PC

notstpaul

Active Member
Joined
Sep 29, 2007
Messages
90
After ditching ADSL and getting an 8ta dongle (ironically) I didn't have WiFi as my router doesn't have a USB slot to take the 3G dongle.

I found the following article very useful, but had to make a couple of changes (see after the quote) to get it to work for me:
http://superuser.com/questions/241651/setting-up-wifi-router-as-a-switch-for-internet-connection-sharing (pasted below)
Also, I didn't feel like finding out why those particular IP addresses need to be used, but they work and were mentioned in other similar articles. Anyone is welcome to explain. :)
How to configure a Wi-Fi router to share your computer's 3G data stick connection to everyone.

  1. Connect to the Internet on your 3G data stick.
  2. Plug your laptop to one of the router's LAN ports. Wait until the router connects correctly.
  3. Click Start > Control Panel > View Network status and tasks > Change adapter settings
  4. Right click the modem (or the connection where you get Internet from) > Status > Details. Write down the "IPv4 DNS Servers" on a piece of paper. Click Close once.
  5. Right click the Local Area Network > Status > Details. Write down the "IPv4 Default Gateway". Click Close > Close.
  6. Open the browser and type the IPv4 Default Gateway on the addressbar. Routers are all different so you need to figure out where to find and configure the following:
    • Review your wireless security settings. What is your SSID? What is your security key? Write this down.
    • Under WAN, choose "Static IP" instead of "PPPoE" or "Automatic - DHCP".
    • Under WAN, set the WAN IP to 192.168.137.2
    • Under WAN, set the Netmask to 255.255.255.0
    • Under WAN, set the Gateway to 192.168.137.1
    • Under WAN, set the DNS Server(s) to the "IPv4 DNS Servers" you got from step 4.
    • Click Save.
  7. Unplug your laptop from the router's LAN port and plug it to the WAN port. Wait until the router connects correctly. [me: N/A for my router]
  8. Go back to the "Network connection" screen on Step 4 > Properties > Sharing >
    • Check "Allow other network users to connect through this computer's Internet connection."
    • Under Home networking connection choose "Local Area Connection" [me: :confused: didn't find this. Probably for Windows XP.]
    • Click OK then OK.
  9. Right click the Local Area Network > Status > Details. Is the IPv4 address "192.168.137.1"? If yes, then you're done! Tell everyone to connect to the wireless router and they will be online.
NOTE: There's a router-less method using "ad-hoc networks", but using a router provides more range and can handle more connected computers or wifi phones.​

To put things back to before.
  1. Uncheck the "Allow other network users to connect through this computer's Internet connection." on Step 7. Click OK.
  2. Unplug the laptop from the router's WAN port and plug it into one of its LAN ports.
  3. Open a browser and visit the "IPv4 Default Gateway" address you got from Step 5.
  4. Switch the WAN setting from "Fixed IP" back to "Automatic - DHCP". Save changes.
  5. You're done!

Only one more thing: Sometimes, after the configuration, it is necessary to restart your modem, computer and router. In one situation, I connected them in this way. Modem → My Computer → Router → all other devices (like laptop, network printer, other computer).
My additional notes:
(I'm using Win 7. My router is a Netgear DGN1000.)

  1. To be able to enter the static IP address one needs to tell the router that no internet login is needed.
  2. I had to enter separate details in the LAN setup for the router. The IP address is as above 192.168.137.2 and the subnet mask 255.255.255.0
  3. Make sure you turn OFF the router as a DHCP server!
  4. I didn't have an option to unplug the computer from the LAN port and insert into the WAN port of the router (whatever that means), so I left as is and did the following:
  5. On the computer, on Network and Sharing Centre go to Change Adapter Settings, right click Local Area Connection > Status > Properties > Internet Protocol Version 4 (TCP/IPv4) > Properties.
  6. Set the IP address to 192.168.137.1 and the subnet mask to 255.255.255.0. I left the Default Gateway and the DNS servers blank.

Bingo. My cellphone connects to the WiFi!
 

Slootvreter

Honorary Master
Joined
Aug 7, 2008
Messages
28,402
If this works, you should be able to share any network connection with a wireless router?
 

Barge

Well-Known Member
Joined
May 26, 2007
Messages
346
At my work, I have my XP PC's DNS set to the router gateway address - 10.0.0.1 in that case, as I was having difficulty with automatically assigned DNS.

Would a similar approach apply in this situation, that one sets the DNS address in the wifi router to the gateway address of the PC i.e. 192.168.137.1. Then if your wireless ISP changes DNS servers for any reason, at least one does not need to change any settings in the router, as it is having the DNS assigned by the PC.

I don't know whether one can compare these two cases? Perhaps unnecessary, as on a 3G connection, one is unlikely to use different DNS servers.
 

gelde03

New Member
Joined
Jul 6, 2014
Messages
4
After ditching ADSL and getting an 8ta dongle (ironically) I didn't have WiFi as my router doesn't have a USB slot to take the 3G dongle.

I found the following article very useful, but had to make a couple of changes (see after the quote) to get it to work for me:
http://superuser.com/questions/241651/setting-up-wifi-router-as-a-switch-for-internet-connection-sharing (pasted below)
Also, I didn't feel like finding out why those particular IP addresses need to be used, but they work and were mentioned in other similar articles. Anyone is welcome to explain. :)


My additional notes:
(I'm using Win 7. My router is a Netgear DGN1000.)

  1. To be able to enter the static IP address one needs to tell the router that no internet login is needed.
  2. I had to enter separate details in the LAN setup for the router. The IP address is as above 192.168.137.2 and the subnet mask 255.255.255.0
  3. Make sure you turn OFF the router as a DHCP server!
  4. I didn't have an option to unplug the computer from the LAN port and insert into the WAN port of the router (whatever that means), so I left as is and did the following:
  5. On the computer, on Network and Sharing Centre go to Change Adapter Settings, right click Local Area Connection > Status > Properties > Internet Protocol Version 4 (TCP/IPv4) > Properties.
  6. Set the IP address to 192.168.137.1 and the subnet mask to 255.255.255.0. I left the Default Gateway and the DNS servers blank.

Bingo. My cellphone connects to the WiFi!
Awesome write-up!
Took me a week to figure out how to setup my Mecer E5104N2 router for this, but eventually got it right.
Surfing or updating mobile apps while at home.
Thanks notstpaul!
 
Top