Vodacom E220 Usb Modem on Ubuntu 11.10

Sumio

Well-Known Member
Joined
Nov 4, 2011
Messages
128
I recently installed Ubuntu 11.10, and tried to connect my Vodacom 3G Usb modem up and just experienced total anguish.
There seems to be something wrong in Oneiric, as the network manager or nm-applet does not register this modem. When I previously
connected the same modem to other versions of Ubuntu (karmic) - the connection was instant, and I did not have any problems.
I did find a temporary work around, using my 2g phone.

First I ran "lsusb":
Bus 001 Device 026: ID 12d1:1003 Huawei Technologies Co,, Ltd. E220 HSDPA Modem / E230/E270 HSDPA/HSUPA Modem

Then the only command that worked was this:
sudo usb_modeswitch -v 0x12d1 -p 1003 -V 0x12d1 -P 1003 -R

After that command, it said
"no switching method given. Resetting usb device. Ok, device was reset. Run lsusb to note any changes. Bye."

When I ran lsusb again, the output was the same - so I figured this is a temporary workaround. I got the usb_modeswitch command from a link I found on my cellphone, and will post it when I can. It did work though:) I apologize for the limited output I provided, the default terminal installed with Oneiric does not seem to support copy functions. I would appreciate any help to provide a permanent fix, or if someone could explain the "usb_modeswitch" command.
 

MyWorld

Executive Member
Joined
Mar 24, 2004
Messages
5,001
The copy and paste has nothing to do with the terminal. Just highlight the text, do not right click just highlight the text, go to the place you want to paste and just middle mouse button click.

Anyway, hope you get the modem going!
 

volstruis

Senior Member
Joined
Aug 30, 2006
Messages
595
I had the same issue. This with he fact that Unity actually sucks I moved to mint.
 

Knyro

PhD in Everything
Joined
Jul 5, 2010
Messages
29,491
The latest Ubuntu is terrible when it comes to wireless networking. I could not detect my wireless router 8/10 times and when I did finally manage to connect it would only stay connected for a few minutes before disconnecting and refusing to reconnect unless I restarted. Eventually Ubuntu didn't even manage to detect my built in wireless card.

If all else fails you may want to look into installing Wicd and removing Network Manager.
 

darkevil

Senior Member
Joined
Mar 17, 2008
Messages
718
Launch your modum

Do not connect

open up a terminal

type in sudo ifconfig usb0 -arp
type in your password.

Connect your modem.

This procedure needs to be done every time you want to connect.

This is the only way i get my modem to allow me onto the net.

Trust this will work for you.


Permanent solution
Solution...
Open up a terminal.ctrl alt T
Type in sudo -i
Type in your password.

That will take you to root.

Now we need to create two scripts.
type in...cd /etc
type in...cd udev
type in...cd rules.d
Now lets create our first script
Type in...nano 10-vodafone-fix.rules
This will open up a script
Type in the script.KERNEL=="usb0", RUN+="vodafone-fix.sh"

With that done.
press...ctrl o
You will be prompted to save the file.
Press enter.
Now press ctrl x
That should take you back to the terminal.
Now for the second script.

In the terminal.
Type in ..cd /lib
type in ..cd udev

Now type in nano vodafone-fix.sh
That will open up a new script.
Type into the script.
#!/bin/sh
ifconfig usb0 -arp

now press ctrl o

You will be prompted to save the file.
Press enter.

Now press ctrl x

That will once again take you to the terminal.

Now in the terminal type in......chmod +x vodafone-fix.sh
 
Last edited:
Top