VOIP remains on registration: inactive

Pyro

Expert Member
Joined
Dec 8, 2003
Messages
2,267
Hi Guys,

I'm in the process of porting my old number to iConnect.
I understand the service is backed by ECN.

The VOIP is working, as I can use the same credentials from an app (SipDroid) on android to make calls.

I've got a Zyxel VMG8924-B10A, but the actual connection is made through a MikroTik router.

I've added the connection details as a SIP Provider, and added my credentials and activated the account.

Under VOIP status, it remains as Registration: Inactive though, and I see no connections going out of the network.

The router shows it's connected to the internet which it accesses through the WAN port.

I've tried it with NAT & SIP ALG both on and off, but it seems to remain inactive.

---

Any clues as to what I'm missing?

Thanks!
 

Pyro

Expert Member
Joined
Dec 8, 2003
Messages
2,267
On a related note - what must the phone settings be?

There is no region for South Africa, and I'm not sure if I should use the US or Europe call service type.
 

sajunky

Honorary Master
Joined
Nov 1, 2010
Messages
13,125
You don't say how Zyxel is configured. DSL bridge or a router? If former, it is simple in automatic mode. If later, then NAT port forwarding for SIP (according to your SIP server) is required on Zyxel or just put Mikrotik IP in DMZ (if you have such option on Zyxel). On Mikrotik configure WAN interface IP, DNS and default gateway. Then enable SIP ALG on Mikrotik for the SIP clients connected to Mikrotik.
 

Pyro

Expert Member
Joined
Dec 8, 2003
Messages
2,267
Zyxel is wan-bridged to the mikrotik, so I assumed it would be basic.

For some reason I do not have the SIP ALG on the mikrotik and couldn't figure out where I can get it for the 6.40.4 MIPSBE version in running on there.

Since the Android phone connected to the zyxel wifi works without any changes it I assumed it's not necessary.

I tried opening the nat for the relevant sip ports I could find as well as allowing connections from sip, but couldn't see any connections coming from the zyxel for sip.

What bothers me is that it never fails registration.
 

sajunky

Honorary Master
Joined
Nov 1, 2010
Messages
13,125
Well, in that case problem is with Mikrotik.
Consumer grade products have gateway functions like SIP ALG. With Mikrotik if you have strict symmetric NAT you must know what you are doing. Perhaps there are people familar with this product, they may help.
 
Top