Axxess ISP SSH sessions always breaking due to load balancer??

Vander Host

Member
Joined
Apr 16, 2019
Messages
28
I live in Cape Town and have tried various providers across the Western Cape. My residence is in Tamboerskloof and my landlord uses Axxess. I'm 90% happy with the service but I have one major problem in my daily workflow which is becoming a royal pain in the neck.

The problem is SSH breaks. It works for a little while, say 5 or 15 minutes, but then I have to restart the SSH terminal and start a fresh session. And yes I am familiar with screen but the point of this post, and what I'm trying to get to the bottom of, is this *is not supposed to happen*.

I've tried a number of other ISPs and on most of them my SSH sessions lasts for days.

All I can think is Axxess has some kind of load balancer that's trying to balance the load and in the process breaks SSH.

Any ideas? I can't exactly ask my landlord to change his provider, and as I say, we're mostly happy. But at this point, when I have 10 SSH sessions open and they start breaking one by one, I loose it. This has been ongoing for over a year and a half.

PLEASE HELP ME
 
Who is the FNO? Maybe try a continuous ping to your host and see if there are any drops. Loadbalancing typically keeps sessions sticky to a path to avoid this sort of thing.
 
> Who is the FNO?
I don't know who the FNO is but I've seen Vumatel driving around here.

> Maybe try a continuous ping
General connectivity isn't an issue - just SSH. No ping loss ever. SSH break to "nearby" and "far" SSH servers, e.g. Cape Town, Johannesburg, London, US-West, etc.
 
Did you try other ISP's on the same router?
Could be the NAT connection tracking being broken/corrupt or on a static timeout setting on the router

As a quick workaround you could try going through Cloudflare Warp while you are working, it uses Wireguard which uses udp so should be connectionless (I think the PC app is still in beta)
 
I live in Cape Town and have tried various providers across the Western Cape. My residence is in Tamboerskloof and my landlord uses Axxess. I'm 90% happy with the service but I have one major problem in my daily workflow which is becoming a royal pain in the neck.

The problem is SSH breaks. It works for a little while, say 5 or 15 minutes, but then I have to restart the SSH terminal and start a fresh session. And yes I am familiar with screen but the point of this post, and what I'm trying to get to the bottom of, is this *is not supposed to happen*.

I've tried a number of other ISPs and on most of them my SSH sessions lasts for days.

All I can think is Axxess has some kind of load balancer that's trying to balance the load and in the process breaks SSH.

Any ideas? I can't exactly ask my landlord to change his provider, and as I say, we're mostly happy. But at this point, when I have 10 SSH sessions open and they start breaking one by one, I loose it. This has been ongoing for over a year and a half.

PLEASE HELP ME
You can try this type of setting which helps with 3g connections in your ssh client:

1609756388019.png
 
Hi guys,

Thanks so much for all the technical workarounds. I use Linux so the last one unfortunately isn't relevant to me.

What I'm after is someone else SSH experience on Axxess's network? Preferably someone who lives in the Cape because at times I see my breakout is Port Elizabeth or Johannesburg and that could be part of the problem?

And also please note without touching a thing my laptop works perfectly on other networks? So problem is at Axxess not my PC?
 
Hi guys,

Thanks so much for all the technical workarounds. I use Linux so the last one unfortunately isn't relevant to me.

What I'm after is someone else SSH experience on Axxess's network? Preferably someone who lives in the Cape because at times I see my breakout is Port Elizabeth or Johannesburg and that could be part of the problem?

And also please note without touching a thing my laptop works perfectly on other networks? So problem is at Axxess not my PC?
Try something like this then:

ssh -o ServerAliveInterval=30 -o ServerAliveCountMax=1 $HOST
 
> Try something like this then:
> ssh -o ServerAliveInterval=30 -o ServerAliveCountMax=1 $HOST

@razed ,

Fantastic! That worked. Thanks so so much! :)
 
Eugene,

A bit late to the party here, but why not try something like Mosh which isn't affected by SSH latency or timeouts - as an example you could enter a lift, go up 10 floors, get out and still maintain an active SSH session. That and it eliminates perceived SSH lag.

 
Thanks so much @jsheed_sa ! That looks like a really useful tool :)

I am however heavily vested in my current setup and workflows and have 80 keys to manage. So the final piece of the puzzle to make every single SSH session work reliably on an Axxess fibre line is:

~ cat .ssh/config
Host *
ServerAliveInterval 30
ServerAliveCountMax 1
Found this advice at: https://linuxize.com/post/using-the-ssh-config-file/

@razed I've immortalized your advice in a knowledgebase article here. If you want me to do an additional shoutout or link to your website or profile please let me know! :)

https://vander.host/knowledgebase/o...-ssh-terminal-sessions-on-an-unreliable-link/
 
Back
Top