Cell C Network Issues: Disconnects, Coverage, Throughput Problems - Report Here

Cell_C

Cell C Representative
Company Rep
Joined
Sep 7, 2010
Messages
2,952
#1
Network Notices
none

Location specific Problems
HSPA+ Speeds in Gauteng Region - Known Issue (From Cell C)
Network Issues since January 1 - Western Cape
Slow upload speeds in Cape Town
Network Issues Stellenbosch
Brackenfell & Kraaifontein
3G speeds in the Berea Musgrave Morningside area

Known Problems
Stuck on EDGE, unable to switch to 3G (E1820 / E1752?)
Connected but no throughput
Constant Disconnects
Inbound Connections / Unrestricted APN
Cell C E1820 External Antenna Connector

Fix in place - Monitoring
none

Recently Resolved
Still connected but only able to access Cell C website
Data bundles not available 2011/02/07
Cell-C E1820/E1752 Dashboard Software "WCDMA only"
Motorola Defy from Red Bull Mobile doesn't have RBM portal Fix here: Setting up Android RBM

Self Help
1) Read the FAQ in this forum.
2) Read the Cell C FAQ.
3) Search this forum, and chances are your question has been answered before.

How To Report Issues
For reporting issues to Cell C Support
1) Call 084 155 5555 technical helpdesk, free from a Cell C SIM.
2) Mail online support on onlinesupport@cellc.co.za or PM Cell_C with the following information (all fields mandatory, email preferred)
First and Last name:
Contact Number:
Email Address:
Number of effected SIM:
Type of service (pre- or post-paid):
Physical address, location or Coordinates:
Time of Issue:
Dongle / handset used, Make and Model:
What OS and version are you using on the connecting device (Windows / Mac / Linux):
www.speedtest.net results (if possible):
Full description of the problem with as much detail and history as possible:
Some questions to consider:
  • Data Problem (GPRS/EDGE/3G)?
  • Unable to connect to the Internet?
  • Internet connection times out?
  • Data throughput is very low (<100Kbps)?
  • Data throughput is good but not excellent (<2Mbps)?
  • Cannot access a specific site?
  • Cannot access specific service (e.g. E-Mail, VPN or BlackBerry)?
  • Is this a recurring problem?
  • Have you called in the past Cell-C for the same problem?
  • How long ago have you registered the same complaint?
  • You know of anyone else that experiences the same issue?

For reporting New Problems in this thread (all the information is required)
Location:
Date & Time of Issue:
Device Manufacturer & Model (e.g. Huawei E1820, ZTE MF190, Not: Black Modem, White Modem):
Contract Type (pre- or post-paid):
Existing reference numbers from Helpdesk:
RAT (2G/3G/HSPA+):
www.speedtest.net results (if possible):
Cell ID (if possible):
RSSI (if possible, see How to check signal strength (RSSI))
Any other information relevant to the problem:

Moderator Note: Incomplete posts in this thread will be deleted. If you start a new thread to report network/data related issues without the required information it will be deleted. Do your bit to assist the rep so you can be helped in the most efficient manner.
 
Last edited by a moderator:

morkhans

A MyBroadband
Super Moderator
Joined
Jun 22, 2007
Messages
10,487
#2
I WILL be deleting incomplete posts or new threads relating to network issues. You have been warned.
 

Dolby

Honorary Master
Joined
Jan 31, 2005
Messages
25,074
#4
Location: Randpark Ridge
Time of issue: 10.22am
Device: Black Cell C modem
Contract Type (pre- or post-paid): Prepaid
Existing reference numbers from Helpdesk: n/a
www.speedtest.net results (if possible): n/a
Any other information relevant to the problem: Randpark Ridge down for days - with no throughput at all. I've noticed the past 4 days - but plenty of others say around a week. Note this is not just slow ... this is ZERO.

All good, Mr Mod?
 
Last edited:

gifs

Expert Member
Joined
Mar 1, 2007
Messages
1,376
#6
Location: Northcliff
Time of issue: last couple of days
Device: Black Cell C modem E1820
Contract Type (pre- or post-paid): Prepaid
Existing reference numbers from Helpdesk: Couldn't be bothered to try, takes too long to answer and I have to pay for the call.
www.speedtest.net results (if possible): n/a
Any other information relevant to the problem: My internet has been down for days. Mostly no throughput at all even though the modem connects and shows decent signal strength. Intermitantly I can get some slow throughput for a couple of minutes, but that is the exception rather than the norm. My flatmate has exactly the same issue, so you can rule out my PC or any of the normal things you blame.
 

slave

Active Member
Joined
Oct 13, 2009
Messages
79
#7
Location: Randpark Ridge
Time of issue: From 14:00 today (bearing in mind I collected my 'speed'-stick at 13:00
Device: Black Cell C modem E1820
Contract Type (pre- or post-paid): Postpaid
Existing reference numbers from Helpdesk: Couldn't be bothered to try, takes too long to answer and I have to pay for the call.
www.speedtest.net results (if possible): Tried but it was painfully slow so I gave up.
Any other information relevant to the problem: I checked coverage of my address on the Cell C site and was happy to see that I was covered. Signed up and collected my USB modem today, rushed home and have had nothing but whooshing (NOT) speeds averaging 40Kbps. It takes over 2 minutes just to load a forum page. Where is the speed that everyone's raving about? At this rate I'll be missing my dial-up days. Is this the norm for this area in which case I'm cancelling. I even drove around the area and all I got was EDGE, not a sniff of UMTS.
 

Dolby

Honorary Master
Joined
Jan 31, 2005
Messages
25,074
#9
Location: Randpark Ridge
Time of issue: From 14:00 today (bearing in mind I collected my 'speed'-stick at 13:00
Device: Black Cell C modem E1820

FYI - Randpark Ridge and surrounding areas have been out for 5 days now. A number of others are reporting issues in Randburg and Randpark Ridge too. Don't hold your breath that you'll be whooshing anytime soon. I wonder if they'll give us extra data as we're approaching 20% of the month being down - and using Vodacom as a backup means bread and water for the the rest of the month due to the high costs?

EDIT : But I've had it since December and it actually isn't the norm. I've typically had about 2-3mbps downloads over the months which is ideal for my needs. I must say though, having used Vodacom the past few days I've been getting 5+mbps everytime.
 
Last edited:

Dolby

Honorary Master
Joined
Jan 31, 2005
Messages
25,074
#12
Thanks for the info. If I'm given the option to cancel what would you recommend? Based on your response I'm inclined to think I should allow myself to be ripped by VC.
I've used Vodacom, Telkom and Cell C in this area - and the only constantly good one was Telkom.

Vodacom went from bad to worse in 2009 - which caused me to jump to Telkom.
From Telkom I jumped to Cell C because of cost and - up until 5 days ago - it wasn't too bad either.
However now that I'm using the VC SIM again, it's performance is the best.

5 months ago I got VC (>1mbps), Telkom (3mbps) and Cell C (3mbps). Now I get VS (5+mbps), Telkom (3mbps) and Cell C (dead) - so tough call ;)

Personally I'd wait a day or two to see if Cell C sorts themselves out as I feel the cost saving over Vodacom is worth slightly slower performance (if it works properly again!)
 

Jer1cho

Active Member
Joined
May 6, 2009
Messages
75
#13
Location: Northgate (Johannesburg)
Time of issue: From 19:00 Thursday 21 April 2011
Device: Black Cell C modem E1820
Contract Type (pre- or post-paid): Prepaid
Existing reference numbers from Helpdesk: 136475
www.speedtest.net results (if possible): No Internet connectivity, so test impossible.
Any other information relevant to the problem: Connects, but there is no throughput at all. Connecting to EDGE works, but WCDMA is dead. When putting the SIM card in my Galaxy i9000, no icons for 3G or HSDPA show up. This immediately tells me that something is wrong. When going to Cell C in Northgate mall, they informed me that the whole of Randburg is out, and nothing is being done to fix it.

I lost nearly 10GB because of useless service in replacing a faulty speedstick. That process took nearly 2 months. Now when i get my modem back, I am going to end up losing another 3GB thanks to this. Well done Cell C.
 

stacatto

New Member
Joined
Apr 26, 2011
Messages
1
#14
Location: Randburg Cresta area
Time of issue: About five days now
Device: Black Cell C modem
Contract Type (pre- or post-paid): Prepaid
Existing reference numbers from Helpdesk: n/a
www.speedtest.net results (if possible): n/a
Any other information relevant to the problem: Zero thoroughput - this is scandalous!

Guys, has anyone considered approaching the Consumer Forum for a full refund. I am not sure Cell C is geared up to provide such a service on a large scale - clearly they are battling with the technical issues. The call centre is no good.
 

gifs

Expert Member
Joined
Mar 1, 2007
Messages
1,376
#15
Location: Northcliff
Time of issue: last couple of days
Device: Black Cell C modem E1820
Contract Type (pre- or post-paid): Prepaid
Existing reference numbers from Helpdesk: Couldn't be bothered to try, takes too long to answer and I have to pay for the call.
www.speedtest.net results (if possible): n/a
Any other information relevant to the problem: My internet has been down for days. Mostly no throughput at all even though the modem connects and shows decent signal strength. Intermitantly I can get some slow throughput for a couple of minutes, but that is the exception rather than the norm. My flatmate has exactly the same issue, so you can rule out my PC or any of the normal things you blame.
My cellc internet started working some time this afternoon.
 

Cell_C

Cell C Representative
Company Rep
Joined
Sep 7, 2010
Messages
2,952
#16
Location: Randburg Cresta area
Time of issue: About five days now
Device: Black Cell C modem
Contract Type (pre- or post-paid): Prepaid
Existing reference numbers from Helpdesk: n/a
www.speedtest.net results (if possible): n/a
Any other information relevant to the problem: Zero thoroughput - this is scandalous!

Guys, has anyone considered approaching the Consumer Forum for a full refund. I am not sure Cell C is geared up to provide such a service on a large scale - clearly they are battling with the technical issues. The call centre is no good.
Good day stacatto

please can you use a program called mdma , to get the tower id (cell id )
at do a speed test www.speedtest.com
and ill try help you to the best i can

regards
~AM~
 

Dolby

Honorary Master
Joined
Jan 31, 2005
Messages
25,074
#17
I'm still down ... 7 days flat now.

I started MDMA and watched for a few minutes as RSSI jumped from -81 to >113 and back continually.

Occasionally locks onto tower 31260 - but often the Cell I'd is just blank

What is the issue exactly? Seems a large portion is out - about 4 neighbouring suburbs

I've spent R100s of rand staying connected this week ... And although Vodacom was bad, I was never down 25% of a month!
 

147GTA

New Member
Joined
Apr 27, 2011
Messages
8
#18
Location: MIDRAND, Carlswald AH
Time of issue: 7 Days now
Device (Huawei / ZTE): Huawei White stick
Contract Type (pre- or post-paid): Pre
Existing reference numbers from Helpdesk: submitted but none yet
www.speedtest.net results (if possible): not possible
Any other information relevant to the problem: ZERO throughput. Works fine for ~30s after connecting, thereafter tower ignores the modem 99 times out of 100.

Very frustrating. Like others here, I posted this via Vodacom - can't use cell C for anything.
 

Dolby

Honorary Master
Joined
Jan 31, 2005
Messages
25,074
#19
http://mybroadband.co.za/photos/showphoto.php?photo=22820&cat=500

I had no signal for a number of days early April - and now 8 days with nothing .... approaching half the month.
I have around 3GB left (I can't use) and spent close to R500.00 this month to use my backup 3G.
I've watched RSSI jump from -81 to >113 constantly over a few minutes - as well as cycle between cell ID 13703, 10423, 3126 and one other - but most the time it doesn't give any ID.

Could somebody PLEASE do something?
 
Last edited:

jem

Well-Known Member
Joined
Jan 9, 2008
Messages
361
#20
Location: PRETORIA, Villieria
Time of issue: 4 Days now
Device (Huawei / ZTE): Huawei Black stick
Contract Type (pre- or post-paid): Pre
Existing reference numbers from Helpdesk: will submitted tomorrow
www.speedtest.net results (if possible): 0.21 down 0.15 up
Any other information relevant to the problem: Last 4 days speed is non-existant. Not router, tested directly on pc as well.

Edit: Previous to this I was getting 9-11mbit/s down and ~3.5up
 
Last edited:
Top