Ford Figo 1.4 TDCI - shakes when accelerating or decelerating

Joined
Jun 29, 2016
Messages
11
Hey guys. I've owned a 2014 Ford Figo 1.4 TDCI Ambiente for about 2 years now, 115 000km on the clock. Engine is quite punchy and fuel effecient.

However, when driving and letting go of the accelerator and then pressing again, the whole car shakes forwards/backwards (I hope this description makes sense). Several google searches suggest looking at engine and gearbox mounts but on my last service (at 105 000km) the guys at Ford Fourways said the mounts seem fine and aren't sure what this is caused by. Others have suggested inspecting the throttle body but I'm not entirely sure if diesel engines have throttle bodies.

Does anybody have a similar car and experiences similar symptoms? Is there a way to check mounts without taking anything apart under the hood to look at them? Do those driving the petrol variant have the same issue?

Thanks in advance.
 

qscwbt

Expert Member
Joined
Feb 24, 2014
Messages
1,826
Difficult one, I suggest taking car in.

Could be:

clutch
Duel mass flywheel failure
Vacuum leaks
wastegate on turbo sticky
Boost leaks
MAP sensor
Blocked soot filter in exhaust.
Throttle body (newer design turbo diesels now use throttle bodies)
 
Joined
Jun 29, 2016
Messages
11
Difficult one, I suggest taking car in.

Could be:

clutch
Duel mass flywheel failure
Vacuum leaks
wastegate on turbo sticky
Boost leaks
MAP sensor
Blocked soot filter in exhaust.
Throttle body (newer design turbo diesels now use throttle bodies)
I might do just that, thanks. Now it's only a matter of finding good mechanics around me
 
Joined
Jun 29, 2016
Messages
11
EDIT: using a bottle of Wynn's Injector and Turbo Cleaner with a full tank of diesel seems to temporarily solve the problem for about a month or 2. Also starting or turning the engine off gets the whole car to shake/vibrate. Could be just a diesel engine rattling thing, yes?
 

namzsteve

Expert Member
Joined
Oct 12, 2012
Messages
2,679
Engine mounts?

Throttle body
Transmission issue
Maybe even some suspension components

Does it shake when you're slowly drive off?
 

upup

Executive Member
Joined
Jun 1, 2009
Messages
6,312
EDIT: using a bottle of Wynn's Injector and Turbo Cleaner with a full tank of diesel seems to temporarily solve the problem for about a month or 2. Also starting or turning the engine off gets the whole car to shake/vibrate. Could be just a diesel engine rattling thing, yes?
something fuel line sticky then
 

namzsteve

Expert Member
Joined
Oct 12, 2012
Messages
2,679
Usually depends on my clutch balance/control when driving off
Try taking off without accelerating, if it shakes too much it has to be a mechanical thing.

Clutch
Have you recently changed your clutch? Maybe the clutch kit itself is due.

Then try taking off using a lot of accelerator pedal, if it doesn't shake a lot then it could point to the engine mountings, especially the one right at the rear bottom of the engine.
 

bromster

Expert Member
Joined
Nov 2, 2012
Messages
4,329
EDIT: using a bottle of Wynn's Injector and Turbo Cleaner with a full tank of diesel seems to temporarily solve the problem for about a month or 2. Also starting or turning the engine off gets the whole car to shake/vibrate. Could be just a diesel engine rattling thing, yes?
Number 2 screams engine mounts. Remember there's one underneath too, near the gearbox
 

ReeceDBN031

Senior Member
Joined
Aug 28, 2018
Messages
803
correct me if i am wrong but another way to check that bottom mount... need a buddy to start the car.. the give a few revs as you watch the motor itself.. if it twists a hella lot then the bottom mount is effed??
 

ReeceDBN031

Senior Member
Joined
Aug 28, 2018
Messages
803
I remember when i had my Mps, motor used to twist alot which is not laka for acceleration.. so i put a custom mount in to make it extra stiff.. help for quicker takeoffs etc.. was a little more vibration than usual.. but nothing too crazy
 
Top