Opel corsa lite 2004.

Kylet

Member
Joined
Jul 21, 2019
Messages
28
Hi I bought this Opel corsa kite a few months back and ever since I had the car it had a pre ignition when I turned off the car after driving it, when the pre ignition comes as I switch the car off, then the battery light would come on as the car pre igntions then the light would go off as the pre ignition stops, it is getting annoying and I am worried about it damaging my engine.

I done some research on the problem, one thing that can cause a car to do this is a bad knock sensor, a mechanic told me it could be the ignition switch. Can anyone help me with this because I do not know where to start?

The image below is an unplugged cable which is located about the starter, seems to me like the previous owners unplugged this, does anyone know what this came is and why it could be unplugged?
 

Attachments

  • IMG_20191111_144622.jpg
    IMG_20191111_144622.jpg
    1,002.7 KB · Views: 13
  • IMG_20190722_115232_552.JPG
    IMG_20190722_115232_552.JPG
    58.3 KB · Views: 13

FiestaST

Honorary Master
Joined
Aug 9, 2009
Messages
79,567
Have a lookie:

 

ubercal

Expert Member
Joined
Dec 5, 2005
Messages
2,791
Hi I bought this Opel corsa kite a few months back and ever since I had the car it had a pre ignition when I turned off the car after driving it, when the pre ignition comes as I switch the car off, then the battery light would come on as the car pre igntions then the light would go off as the pre ignition stops, it is getting annoying and I am worried about it damaging my engine.

I done some research on the problem, one thing that can cause a car to do this is a bad knock sensor, a mechanic told me it could be the ignition switch. Can anyone help me with this because I do not know where to start?

The image below is an unplugged cable which is located about the starter, seems to me like the previous owners unplugged this, does anyone know what this came is and why it could be unplugged?

have a 1998 corsa lite.Will check and let you know.
 

TheChamp

Honorary Master
Joined
Feb 26, 2011
Messages
36,816
Hi I bought this Opel corsa kite a few months back and ever since I had the car it had a pre ignition when I turned off the car after driving it, when the pre ignition comes as I switch the car off, then the battery light would come on as the car pre igntions then the light would go off as the pre ignition stops, it is getting annoying and I am worried about it damaging my engine.

I done some research on the problem, one thing that can cause a car to do this is a bad knock sensor, a mechanic told me it could be the ignition switch. Can anyone help me with this because I do not know where to start?

The image below is an unplugged cable which is located about the starter, seems to me like the previous owners unplugged this, does anyone know what this came is and why it could be unplugged?
I don't know about the pre ignition but that plug is like that, on mine it's a blue plug.
 
Last edited:

Kylet

Member
Joined
Jul 21, 2019
Messages
28
Thanks for the reply, I don't know much about this cars, but looks like I need to take the car to a mechanic.
 

TheChamp

Honorary Master
Joined
Feb 26, 2011
Messages
36,816
Thanks for the reply, I don't know much about this cars, but looks like I need to take the car to a mechanic.

Have you done anything to the car since buying it, has it been serviced? The Corsa is a trouble free car that is very predictable and there aren't many points of failure. It is usually the coil, spark plugs or HT leads.

Of all the Corsa threads started here the most common problem seems to be misdiagnosis when people rush to fiddle with complicated stuff like the ECU or the injectors, the more you fiddle the more you confuse yourself and the more damage you do.

Make sure you take it to a proper place or someone who knows what they are doing.
 
Top