• You are losing out on amazing benefits because you are not a member. Join for free. Register now.
  • Big Two-Day Giveaway - Win an Amazon Kindle, a Mystery Gadget and Branded Gear. Enter Here.
  • Test your broadband speed and win prizes worth R5,000. Enter here.

Telkom Mobile LTE Speedtest Results

Yuu

Expert Member
Joined
Apr 3, 2006
Messages
4,940
apn was kicking out [TelkomSA default but can only use Telkominternet]. After trying the past 30mins to select the correct apn.

Not too bad this morning.

Ping: 30ms
Download: 45.42Mbps
Upload: 20.13Mbps

:)
 

TheVeteran

Active Member
Joined
Feb 1, 2014
Messages
56
apn was kicking out [TelkomSA default but can only use Telkominternet]. After trying the past 30mins to select the correct apn.

Not too bad this morning.

Ping: 30ms
Download: 45.42Mbps
Upload: 20.13Mbps

:)
Thanks. I'll try changing the apn.

Impressive speeds
 

ghostim

Expert Member
Joined
Dec 27, 2004
Messages
1,130
Ipad mini 4 with prepaid data bundle
Test Date: 26 Mar 2017 09:37
Download: 13.73 Mbps
Upload: 0.92 Mbps
Ping: 17 ms
Connection Type: Cellular
Server: Centurion
 

Yuu

Expert Member
Joined
Apr 3, 2006
Messages
4,940
Ping: 34ms
Download: 47.56Mbps
Upload: 19.82Mbps

:)

Multithreaded download shows upto 7MB/s but constant 6MB/s. Need moar speed :crylaugh:

Openserve London test

Last Result:
Download Speed: 22240 kbps (2780 KB/sec transfer rate)
Upload Speed: 5167 kbps (645.9 KB/sec transfer rate)
Latency: 196 ms
Jitter: 3 ms
2017-3-27 07:51:21

Speedtest London Seacom test

PING
201
ms
DOWNLOAD
16.27
Mbps
UPLOAD
4.51
Mbps

Speedtest beta
 
Last edited:

TheVeteran

Active Member
Joined
Feb 1, 2014
Messages
56
Ping: 34ms
Download: 47.56Mbps
Upload: 19.82Mbps

:)

Multithreaded download shows upto 7MB/s but constant 6MB/s. Need moar speed :crylaugh:

Openserve London test

Last Result:
Download Speed: 22240 kbps (2780 KB/sec transfer rate)
Upload Speed: 5167 kbps (645.9 KB/sec transfer rate)
Latency: 196 ms
Jitter: 3 ms
2017-3-27 07:51:21

Speedtest London Seacom test

PING
201
ms
DOWNLOAD
16.27
Mbps
UPLOAD
4.51
Mbps

Speedtest beta
Thanks. Can't get enough speed lol
Good speeds to London:)
Ping isn't bad as well.
 

Yuu

Expert Member
Joined
Apr 3, 2006
Messages
4,940
@TheVeteran, thanks, as of recent, it ain't consistent. Those speeds deteriorated during the day to as low as a constant 2-3Mbps down. Browsing was okay but not snappy. I don't want to complain to Telkom Mobile just yet :p

mybroadband speedtest just now to CT Server, JHB one is way slower but ping is better :confused:.

Ping: 56ms
Download: 42.67Mbps
Upload: 18.49Mbps

JHB
Ping: 31ms
Download: 32.99Mbps
Upload: 14.71Mbps

Openserve London
2017-03-28_08-40-52.png
 
Last edited:

TheVeteran

Active Member
Joined
Feb 1, 2014
Messages
56
@TheVeteran, thanks, as of recent, it ain't consistent. Those speeds deteriorated during the day to as low as a constant 2-3Mbps down. Browsing was okay but not snappy. I don't want to complain to Telkom Mobile just yet :p

mybroadband speedtest just now to CT Server, JHB one is way slower but ping is better :confused:.

Ping: 56ms
Download: 42.67Mbps
Upload: 18.49Mbps

JHB
Ping: 31ms
Download: 32.99Mbps
Upload: 14.71Mbps

Openserve London
View attachment 426600
Same thing with me today. Extremely low speeds,bad ping and 1 bar of reception from 4. Signal in dB went up by 20-30.
Don't know what's happening. I'll try tonight and tomorrow again. Maybe it's just a one-time thing.
 

Yuu

Expert Member
Joined
Apr 3, 2006
Messages
4,940
Any luck with those of you having bad performance?

Highest i have seen on mybroadband's CT Server speedtest.

Ping: 55ms
Download: 50.86Mbps
Upload: 16.42Mbps

4k Youtube videos stream with about upto 10+- dropped frames, sometimes a refresh due to no local cache on a cdn. Noticed a download earlier at a near constant 7.8MB/s.
 

cavedog

Honorary Master
Joined
Oct 19, 2007
Messages
10,712
Seems the same has happened to you. am i still over reacting...?
Well I moved from Richards Bay to Centurion so it's not the same I think. The Richards Bay tower I was hitting over 80Mbps but in Centurion I'm battling to reach 30Mbps but connection is still very stable.

Just think the tower is congested because the tower is very high and there are tons of estates which it covers.....
 

Gatekeeper

Well-Known Member
Joined
May 11, 2004
Messages
193
Well I moved from Richards Bay to Centurion so it's not the same I think. The Richards Bay tower I was hitting over 80Mbps but in Centurion I'm battling to reach 30Mbps but connection is still very stable.

Just think the tower is congested because the tower is very high and there are tons of estates which it covers.....
Remember cavedog same thing happend to me went from 80 to 60 to 30 then now stuck on 10mb.
this was actually February last year. and still no fix not even icasa wants to help as they cant
the lame Telkom techs have all the excuses to not fix anything. they gave me 2 choices
wait a year for the network to be upgraded or cancel no penalties. really sucks balls :(
 
Top