Afrihost unbale to resolve DSL users DNS resolve issue

Xaze

Active Member
Joined
May 5, 2016
Messages
32
I am at my wits’end about this problem with Afrihost. I am considering getting professional help resolving this so a recommendation for who to use would be appreciated.

The problem is that Afrihost ADSL users are resolved to IP 127.0.0.1 when they attempt to browse to the website www.extremelights.co.za
if they change their DNS server on the routers to 8.8.8.8/8.8.4.4 and flush their DNS cash on the PC the site loads fine.

Using Vodacom/MTN/CELC/Telkom or Afrihost mobile as ISP does not present the same problem.

Using https://www.whatsmydns.net/#A/www.extremelights.co.za it shows that the DNS has propagated correctly.

I have setup a second domain that is parked at Hetzner. It redirects to the same server. it is www.extremelightsmail.co.za it is not affected. I, therefore, conclude that it is not a block by Hetzner of Afrihost IP range or a server/website realted problem.


Routers configuration. I have tested with 169.1.1.1 and 169.1.1.2 as well. The result is the same when using any of the Afrihost DNS servers.

Testing the domian www.extremelights.co.za with tracert and nslookup.


As I have setup a second domain pointing to the same server(129.232.136.42)
I, therefore, can test if the system work


It resolves to the correct server. it is possible to browse to that site but as the images are all on the domain www.extremelights.co.za the site looks broken.

I then change the DNS server on the router to 8.8.8.8 and 8.8.4.4
Flushed the DNS and did the test again






This started on 20 June. My domain www.extremelights.co.za use to use Afrihost as the domain register. One afternoon the domain got suspended out of the blue. We resolved the dispute with Afrihost but I changed the domain to Hetzner where the website is hosted. Sins then customers has been complaining that they can't access our site via AFrihost ADSL connections at home/work.

I do believe the support team at afrihost are trying their best to resolve this but up to now, they have not provided much help. In contract with Hetzner whech was very helpfull and detaild about what they have done and tested. In fact, most of the time Afrihost seem to find bazaar or fuzzy reasons why the problem is not with Afrihost. As I now call and email them daily for the last 2 weeks it is becoming clear that I might need some professional help.
 
Last edited:

Geoff.D

Honorary Master
Joined
Aug 4, 2005
Messages
14,101
I think you are looking in the wrong place.

The problem starts with your ADSL line or exchange, and until you eliminate these, worrying about whether or not the DNS is working properly is confusing the issue.

But you have my sympathy in getting Afrihost to help with line problems and possible "exchange congestion".

Have you tried this simple tool, which will help you in understanding what the problems with your ADSL line may be.
 

BradleyKZN

Expert Member
Joined
Jun 3, 2009
Messages
1,313
I think you are looking in the wrong place.

The problem starts with your ADSL line or exchange, and until you eliminate these, worrying about whether or not the DNS is working properly is confusing the issue.

But you have my sympathy in getting Afrihost to help with line problems and possible "exchange congestion".

Have you tried this simple tool, which will help you in understanding what the problems with your ADSL line may be.
None of these will affect his clients accessing his website.
 

AfriGenie

Afrihost
Company Rep
Joined
Oct 9, 2014
Messages
7,266
I am at my wits’end about this problem with Afrihost. I am considering getting professional help resolving this so a recommendation for who to use would be appreciated.

The problem is that Afrihost ASDL users are resolved to IP 127.0.0.1 when they attempt to browse to the website www.extremelights.co.za
if they change their DNS server on the routers to 8.8.8.8/8.8.4.4 and flush their DNS cash on the PC the site loads fine.

Using Vodacom/MTN/CELC/Telkom or Afrihost mobile as ISP does not present the same problem.

Using https://www.whatsmydns.net/#A/www.extremelights.co.za it shows that the DNS has propagated correctly.

I have setup a second domain that is parked at Hetzner. It redirects to the same server. it is www.extremelightsmail.co.za it is not affected. I, therefore, conclude that it is not a block by Hetzner of Afrihost IP range or a server/website realted problem.


Routers configuration. I have tested with 169.1.1.1 and 169.1.1.2 as well. The result is the same when using any of the Afrihost DNS servers.

Testing the domian www.extremelights.co.za with tracert and nslookup.


As I have setup a second domain pointing to the same server(129.232.136.42)
I, therefore, can test if the system work


It resolves to the correct server. it is possible to browse to that site but as the images are all on the domain www.extremelights.co.za the site looks broken.

I then change the DNS server on the router to 8.8.8.8 and 8.8.4.4
Flushed the DNS and did the test again






This started on 20 June. My domain www.extremelights.co.za use to use Afrihost as the domain register. One afternoon the domain got suspended out of the blue. We resolved the dispute with Afrihost but I changed the domain to Hetzner where the website is hosted. Sins then customers has been complaining that they can't access our site via AFrihost ASDL connections at home/work.

I do believe the support team at afrihost are trying their best to resolve this but up to now, they have not provided much help. In contract with Hetzner whech was very helpfull and detaild about what they have done and tested. In fact, most of the time Afrihost seem to find bazaar or fuzzy reasons why the problem is not with Afrihost. As I now call and email them daily for the last 2 weeks it is becoming clear that I might need some professional help.
Morning!

I just checked with our Server Admins, and from what we can see the issue has been resolved. Our ADSL DNS Servers are resolving to the Hetzner servers for all regions.

Are you still getting complaints from your Clients today?
 

Xaze

Active Member
Joined
May 5, 2016
Messages
32
I think you are looking in the wrong place.

The problem starts with your ADSL line or exchange, and until you eliminate these, worrying about whether or not the DNS is working properly is confusing the issue.

But you have my sympathy in getting Afrihost to help with line problems and possible "exchange congestion".

Have you tried this simple tool, which will help you in understanding what the problems with your ADSL line may be.
I really don't understand why you say the line is the problem as the line works perfectly with other websites aswell as when I change the dns on the router. This is the kind of responses I am getting from afrihost also.
 

Xaze

Active Member
Joined
May 5, 2016
Messages
32
Morning!

I just checked with our Server Admins, and from what we can see the issue has been resolved. Our ADSL DNS Servers are resolving to the Hetzner servers for all regions.

Are you still getting complaints from your Clients today?
I am going to cry :crying:

Ok to test I just teamviewed into the PC at home. See attached the test.


Does that look like it is resolved?

www.extremelights.co.za and www.extremelightsmail.co.za are both pointing to the same server.

Note that I am connecting to the PC via Afrihost ADSL line. So we can assume that is working right?

Can I assume that the Hetzner server is working as I can brows there from the pc at work and get a response from the second domain aswell?

Is there any recomendable professional consultants which I can hire to take charge and help resolve this problem?
 

Geoff.D

Honorary Master
Joined
Aug 4, 2005
Messages
14,101
I really don't understand why you say the line is the problem as the line works perfectly with other websites aswell as when I change the dns on the router. This is the kind of responses I am getting from afrihost also.
Because the trace route results you posted are terrible. I got the wrong end of the stick it seems.
 

Xaze

Active Member
Joined
May 5, 2016
Messages
32
I just did a complete restart. Router and PC.



:wtf:

Is there any recomendable professional consultants which I can hire to take charge and help resolve this problem?
 
Last edited:

Xaze

Active Member
Joined
May 5, 2016
Messages
32
Just for jokes I changed the DNS manualy on the router.



Is there any recomendable professional consultants which I can hire to take charge and help resolve this problem?
 

Rickster

EVGA Fanatic
Joined
Jul 31, 2012
Messages
16,872
Code:
Pinging www.extremelights.co.za [129.232.136.42] with 32 bytes of data:
Reply from 129.232.136.42: bytes=32 time=27ms TTL=55
Reply from 129.232.136.42: bytes=32 time=26ms TTL=55
Reply from 129.232.136.42: bytes=32 time=26ms TTL=55
Reply from 129.232.136.42: bytes=32 time=26ms TTL=55

Ping statistics for 129.232.136.42:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 26ms, Maximum = 27ms, Average = 26ms
Try change the DNS server to 169.1.1.1 and 169.1.1.2
 

Geoff.D

Honorary Master
Joined
Aug 4, 2005
Messages
14,101
Compare the trace route results you posted originally with those you posted now ---- and then tell me the change you made to the DNS is what "fixed" the problem ....
 

Xaze

Active Member
Joined
May 5, 2016
Messages
32
Site works for me on AH.
Are you using fibre or ADSL? Problem sees to be only with ADSL but good to know there might be exceptions. I have 2 others ADSL AH customers, in PE and CT, which I frequnalty contact to check every time AH claimse it has been resolved.
 

Xaze

Active Member
Joined
May 5, 2016
Messages
32
Compare the trace route results you posted originally with those you posted now ---- and then tell me the change you made to the DNS is what "fixed" the problem ....
Correct!. thanks but I can't change every Afrihost user DNS settings that wants to visit my site.
 

Rickster

EVGA Fanatic
Joined
Jul 31, 2012
Messages
16,872
Are you using fibre or ADSL? Problem sees to be only with ADSL but good to know there might be exceptions. I have 2 others ADSL AH customers, in PE and CT, which I frequnalty contact to check every time AH claimse it has been resolved.
1Meg ADSL.
 

Geoff.D

Honorary Master
Joined
Aug 4, 2005
Messages
14,101
Correct!. thanks but I can't change every Afrihost user DNS settings that wants to visit my site.
Have you tried to run something like DNS Benchmark from the site in question when you are having these issues? You may be quite surprised at how often AH DNS servers are shown up to be not performing all that well, and then severely compromised by poor connectivity due to high packet loss.
 

Xaze

Active Member
Joined
May 5, 2016
Messages
32
Code:
Pinging www.extremelights.co.za [129.232.136.42] with 32 bytes of data:
Reply from 129.232.136.42: bytes=32 time=27ms TTL=55
Reply from 129.232.136.42: bytes=32 time=26ms TTL=55
Reply from 129.232.136.42: bytes=32 time=26ms TTL=55
Reply from 129.232.136.42: bytes=32 time=26ms TTL=55

Ping statistics for 129.232.136.42:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 26ms, Maximum = 27ms, Average = 26ms
Try change the DNS server to 169.1.1.1 and 169.1.1.2
Yea tried that before. Does not make much of a difference.

 
Last edited:

Xaze

Active Member
Joined
May 5, 2016
Messages
32
Have you tried to run something like DNS Benchmark from the site in question when you are having these issues? You may be quite surprised at how often AH DNS servers are shown up to be not performing all that well, and then severely compromised by poor connectivity due to high packet loss.
Thanks again. I will ask my server admin to check that but surely then it should be intermitted ?
 

savage

Expert Member
Joined
Aug 11, 2003
Messages
2,922
Your DNS servers are fscked afrihost...

[cknipe@amnesiac ~]$ dig @8.8.8.8 www.extremelights.co.za

; <<>> DiG 9.8.5-P1 <<>> @8.8.8.8 www.extremelights.co.za
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 42511
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;www.extremelights.co.za. IN A

;; ANSWER SECTION:
www.extremelights.co.za. 7191 IN A 129.232.136.42

;; Query time: 266 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Fri Sep 02 13:09:44 SAST 2016
;; MSG SIZE rcvd: 57

[cknipe@amnesiac ~]$ dig @169.1.1.3 www.extremelights.co.za

; <<>> DiG 9.8.5-P1 <<>> @169.1.1.3 www.extremelights.co.za
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 62951
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;www.extremelights.co.za. IN A

;; AUTHORITY SECTION:
extremelights.co.za. 60 IN SOA localhost. root.localhost. 2015111111 600 60 60 60

;; Query time: 27 msec
;; SERVER: 169.1.1.3#53(169.1.1.3)
;; WHEN: Fri Sep 02 13:09:55 SAST 2016
;; MSG SIZE rcvd: 91

[cknipe@amnesiac ~]$ dig @169.1.1.10 www.extremelights.co.za

; <<>> DiG 9.8.5-P1 <<>> @169.1.1.10 www.extremelights.co.za
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 40930
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;www.extremelights.co.za. IN A

;; AUTHORITY SECTION:
extremelights.co.za. 60 IN SOA localhost. root.localhost. 2015111111 600 60 60 60

;; Query time: 82 msec
;; SERVER: 169.1.1.10#53(169.1.1.10)
;; WHEN: Fri Sep 02 13:10:38 SAST 2016
;; MSG SIZE rcvd: 91
 

Xaze

Active Member
Joined
May 5, 2016
Messages
32
1Meg ADSL.
I would love to know why yours work so many others don't. Just makes this problem so much frustrating. every time the phone rings with a customer complains that they can't access our site it is 99% of the time an afrihost customer.
 
Top