Facebook   Twitter    YouTube    RSS Feed    Android App    iPhone and iPad App     BlackBerry App    
Subscribe to Newsletter



Page 1 of 4 1 234 LastLast
Results 1 to 15 of 46

Thread: Android internet and mms settings

  1. #1

    Default Android internet and mms settings

    I got a new HTC Desire and I am having trouble setting up my mms and internet. Tried the helpline but as usual they are of no help...can anyone that maybe also have a android device post their settings please, or point me in the right direction...

  2. #2

    Default

    I'm on MTN but I'll tell you what I was able to find on my device...

    In Settings -> Wirelss & Networks -> Mobile Networks -> Access Point Names (you probably found this already):

    Make sure you've got an APN set up. If not, click the menu button and then "Add." Give your new APN any name, and specify the Virgin APN (don't know what that is off-hand, on MTN and Vodacom it's "internet." My "APN type" is set to "default." It looks like you can just leave the rest of the settings on their defaults (most are <Not set> on mine).

    I see I have two other APNs configured, one which seems to be an alternative to the internet config above, and the other which seems to be for MMS settings. There I can't seem to help you except to tell you that the "APN type" looks like it should be "mms." The other settings (APN, Username, Password, and MMSC) seem to be specific to my operator (MTN).

    Hope this is of some use to you.
    "Beware of he who would deny you access to information, for in his heart he dreams himself your master." ---SMAC

  3. #3
    Grandmaster
    Join Date
    Apr 2008
    Location
    Pretoria
    Posts
    1,151
    Blog Entries
    1

    Default

    I have android on my phone as my secondary but preferred os. All the builds I have run has worked for me thus:

    On the Edit Access points screen (Play around under wireless settings under settings somewhere)
    Menu>Add New
    Name: internet
    Username: (blank-leave it empty)
    Password: (blank-leave it empty)

    Beyond that, no settings must be meddled with. This works with MTN. Maybe the others as well.

  4. #4
    Grandmaster
    Join Date
    Apr 2008
    Location
    Pretoria
    Posts
    1,151
    Blog Entries
    1

    Default

    Extremist beat me to it...please let us know if you came right, and what settings was used.

  5. #5
    Active Member
    Join Date
    Feb 2005
    Location
    Somerset West
    Posts
    82

    Default

    I have my HTC Magic setup with Virgin - maybe this helps:

    1. Go to Mobile Network Settings and then Access Point Names.

    2. Add New APN - I called mine Virgin

    Here I have the following settings:

    Name: Virgin

    APN: vdata

    Proxy: 196.31.116.241

    Port: 8080

    Username: NOT SET

    Password: NOT SET

    Server: NOT SET

    MMSC: NOT SET

    MMS Proxy: NOT SET

    MMS Port: NOT SET

    MCC: 655

    MNC: 07

    APN Type: -

    This has worked for me for over 10 months now.

  6. #6

    Default

    Awesome, thanks a lot guys, my internet is now working. Any ideas on the mms part. Someone sent me one and my phone keeps trying to download it using the internet APN, and its costing me money and doesnt work. I tried entering the mms settings using mtn mms settings as reference, bit it doesnt work, as soon as I change the MNC to 10 (like the mtn's setings) my APN does a vanishing act...no where to be found. If I leave the MNC on default the APN stays but doesnt work. Also how do I set the preffered setting for my phone to use for mms and which to use for internet? Thats if I ever get my mms to work:-). O yeah I used the settings G2V posted. Just entering internet doesn't work. I think it could be because virgin uses cellc network that uses vodacom network! But I could be wrong. Thank you all for the help so far...
    Last edited by lanman; 22-05-2010 at 08:48 AM.

  7. #7
    Active Member
    Join Date
    Feb 2005
    Location
    Somerset West
    Posts
    82

    Default

    Have you tried these setting found in the sticky section of this forum?

    http://mybroadband.co.za/vb/showthre...p-MMS-Settings

  8. #8

    Default

    Yes I did, but as I mention above if I leave the MNC on default it doesnt work and if I change it to 10 like mtn's settings the APN just disappear.

  9. #9

    Default

    Thanks for the info. Got internet to work on Samsung galaxy s with 2.1 but no success with mms so far. Did anyone get them to work?

  10. #10

    Default

    @Tim182, i phoned virgin and they sent me the settings for mms but still no luck. Still trying to figure it out. Hoping the froyo update could maybe be my solution. BTW the settings they sent uses vodacom settings. Will post the settings later, maybe someone can figure something out.

  11. #11

    Default

    Manual MMS Configuration settings
    Step 1. Press the Menu button.

    Step 2. Tap on Settings.

    Step 3. Tap on Wireless controls.

    Step 4. Tap on Mobile network settings.

    Step 5. Tap on Access Point Names.

    Step 6. Tap on New APN.

    Step 7. Tap on Name.

    Step 8. Enter in MMS.Vodacom and tap on OK.

    Step 9. Tap on APN.

    Step 10. Enter in mms.vodacom.net and tap on OK.

    Step 11. Scroll down to MMSC.

    Step 12. Tap on MMSC.

    Step 13. Enter in http://mmsc.vodacom4me.co.za and tap on OK.

    Step 14. Tap on MMS proxy.

    Step 15. Enter in 196.006.128.013 and tap on OK.

    Step 16. Tap on MMS port.

    Step 17. Enter in 8080 and tap on OK.

    Step 18. Tap on APN type.

    Step 19. Enter in mms and tap on OK.

    Step 20. Press the Menu button and Tap on Save.

    Step 21. MMS is now configured.

    I tried the above settings but when trying to send an mms my phone uses the internet apn even after i select the mms apn. I even tried to delete the internet APN but still no luck...

  12. #12

    Default

    Quote Originally Posted by lanman View Post
    Manual MMS Configuration settings
    Step 1. Press the Menu button.

    Step 2. Tap on Settings.

    Step 3. Tap on Wireless controls.

    Step 4. Tap on Mobile network settings.

    Step 5. Tap on Access Point Names.

    Step 6. Tap on New APN.

    Step 7. Tap on Name.

    Step 8. Enter in MMS.Vodacom and tap on OK.

    Step 9. Tap on APN.

    Step 10. Enter in mms.vodacom.net and tap on OK.

    Step 11. Scroll down to MMSC.

    Step 12. Tap on MMSC.

    Step 13. Enter in http://mmsc.vodacom4me.co.za and tap on OK.

    Step 14. Tap on MMS proxy.

    Step 15. Enter in 196.006.128.013 and tap on OK.

    Step 16. Tap on MMS port.

    Step 17. Enter in 8080 and tap on OK.

    Step 18. Tap on APN type.

    Step 19. Enter in mms and tap on OK.

    Step 20. Press the Menu button and Tap on Save.

    Step 21. MMS is now configured.

    I tried the above settings but when trying to send an mms my phone uses the internet apn even after i select the mms apn. I even tried to delete the internet APN but still no luck...
    Running Froyo so I'll test later tonight

  13. #13

    Default

    No luck with those settings on Froyo either (Samsung Galaxy S)

  14. #14
    Grandmaster DJNgoma's Avatar
    Join Date
    Jul 2008
    Location
    Kuala Lumpur, Malaysia
    Posts
    3,095

    Default

    Quote Originally Posted by Tim182 View Post
    No luck with those settings on Froyo either (Samsung Galaxy S)
    Try the following, I've made my own changes to make it hopefully work for Virgin Mobile[Bolded and in Red].

    Manual MMS Configuration settings
    Step 1. Press the Menu button.

    Step 2. Tap on Settings.

    Step 3. Tap on Wireless controls.

    Step 4. Tap on Mobile network settings.

    Step 5. Tap on Access Point Names.

    Step 6. Tap on New APN.

    Step 7. Tap on Name.

    Step 8. Enter in Virgin_MMS and tap on OK.

    Step 9. Tap on APN.

    Step 10. Enter in vmms and tap on OK.

    Step 11. Scroll down to MMSC.

    Step 12. Tap on MMSC.

    Step 13. Enter in http://mms.virginmobile.co.za and tap on OK.

    Step 14. Tap on MMS proxy.

    Step 15. Enter in 196.31.116.242 and tap on OK.

    Step 16. Tap on MMS port.

    Step 17. Enter in 8080 and tap on OK.

    Step 18. Tap on APN type.

    Step 19. Enter in mms and tap on OK.

    Step 20. Press the Menu button and Tap on Save.

    Step 21. MMS is now configured.

  15. #15

    Default

    Doesn't work either. I spoke to some ppl at the virgin store who were selling the SE X10 mini (or galaxy spica, can't remember) which also runs android and they said that they can't even get that to send mms...

Page 1 of 4 1 234 LastLast

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •