YourKaptain

Active Member
Joined
Feb 20, 2018
Messages
39
Ordered new fibre line to be installed on the 11th of August, through Afrihost - after weeks of battling to get the installation date set with Frogfoot, it was finally scheduled by their subcontractor for this morning - Thursday, 27 August 2020.

Installers pulled the fibre, installed the Fibre Termination Box, and left as they promised to return for the ONT Installation within 10-20 Minutes to finalize the installation once the line has been activated.

Numerous e-mails sent to the subcontractor, Frogfoot and Afrihost... still without any further feedback or update of what exactly is going on and the day is passing by....

Any ideas of whom can be contacted to lodge a formal complaint against the subcontractor that Frogfoot is using for their misconduct?

If proper communication and feedback were received from the subcontractor attending to the installation, it would've been a whole other story... But now I am just left with NOTHING...
 
  • Sad
Reactions: Yuu

AfriNatic

Afrihost Rep
Staff member
Joined
Nov 18, 2016
Messages
4,489
Hey,

Sorry for the poor experience that you have received with regards to your installation. Can you send me a private message with your clientzone email so I can assist?
 

Geoff.D

Honorary Master
Joined
Aug 4, 2005
Messages
23,360
Unfortunately, there is no way to ensure fibre continuity until all the splices are completed.
In my case, the fibre cores (2) were terminated in the "fibre termination box", the ONT was set up on my desk, and then the crew left to complete the splice on the pole, came the nothing, because a fault was found at 3 intermediate points before reaching the distribution cabinet. That could not be sorted out in 20 minutes. It turned out the records were wrong, and the pole splice had to be redone on the correct cores.
So this type of delay is apparently pretty common. The ONT cannot be powered up until there pretty much 100 % certainty that fibre is through end to end up to the passive splitter point.
 
Last edited:

powermzii

Expert Member
Joined
Jun 4, 2007
Messages
4,731
Unfortunately, there is no way to ensure fibre continuity until all the splices are completed.
In my case, the fibre cores (2) were terminated in the "fibre termination box", the ONT was set up on my desk, and then the crew left to complete the splice on the pole,cane the nothing, because a fault was found at 3 intermediate points before reading the distribution cabinet. That could not be sorted out in 20 minutes. It turned out the records were wrong, and the pole splice had to be redone on the correct cores.
So this type of delay is apparently pretty common. The ONT cannot be powered up until there pretty much 100 % certainty that fibre is through end to end up to the passive splitter point.

Had a similar issue - contractor then came back 2 days later to complete the installation though. In our case the complex had not even been spliced onto the backhaul and subsequently the splicing of the area was also not completed - seems FF send installation contractors without completely finishing everything - subby mentioned the same
 

Geoff.D

Honorary Master
Joined
Aug 4, 2005
Messages
23,360
Had a similar issue - contractor then came back 2 days later to complete the installation though. In our case the complex had not even been spliced onto the backhaul and subsequently the splicing of the area was also not completed - seems FF send installation contractors without completely finishing everything - subby mentioned the same
It is a bad practice NOT to install, splice and test end to end from the poles or "buddy boxes" to the distribution cabinet and have test results to show performance and continuity. If you don't do this, it means that future crews will be forever be opening up intermediate splice points, running the risk of bringing down working services while they fiddle.
 

YourKaptain

Active Member
Joined
Feb 20, 2018
Messages
39
Update - After sending all relevant info to AfriNatic, the issue was resolved and am up and running. :)

Can absolutely vouch for the Support Afrihost has here on MyBB - beyond amazing and even until now I've been in discussions with them on here!

Huge THUMBS UP and THANKS to @AfriNatic for all the support and assistance provided, sometimes you just need to get through to the right person to assist. :)
 

AfriNatic

Afrihost Rep
Staff member
Joined
Nov 18, 2016
Messages
4,489
Update - After sending all relevant info to AfriNatic, the issue was resolved and am up and running. :)

Can absolutely vouch for the Support Afrihost has here on MyBB - beyond amazing and even until now I've been in discussions with them on here!

Huge THUMBS UP and THANKS to @AfriNatic for all the support and assistance provided, sometimes you just need to get through to the right person to assist. :)

Happy to help ;)
 
Top